Monthly Archives: May 2014

VoCore: AP+STA Power Consume

This is my first time to record a video for VoCore,  some parts are not very clear, next time will be better :)

+5V input, current is about 0.2A when wifi is on. I did not use any power save kernel module or app, amazing! I thought it should be at least 0.25A. :p Its power consume is even less than MT7620A. Wifi output is 100mW.

Youtube: http://youtu.be/uNzgvtOJkmw

Youku(China):http://v.youku.com/v_show/id_XNzE0ODk3NTYw.html

Indiegogo.com: http://igg.me/at/vocore

VoCore: AP+STA Mode

It works. Someone said it is hard and have to change RT5350 wifi driver code, but I did not change any code, maybe the developers of openwrt already fix that? :)

SSID for AP mode is VoCore
SSID for STA mode(my house router) is VongerWifi

That is not hard to setup:

First, enable STA mode, add two lines to the end of /etc/config/network.

config interface wwan
	option proto 'dhcp'

Then change /etc/config/wireless

config wifi-device  radio0
	option type     mac80211
	option channel  11
	option hwmode	11ng
	option path	'10180000.wmac'
	list ht_capab	GF
	list ht_capab	SHORT-GI-20
	list ht_capab	SHORT-GI-40
	list ht_capab	RX-STBC1
	option htmode	HT20

config wifi-iface
	option device   radio0
	option network  lan
	option mode     ap
	option ssid     VoCore
	option encryption none

config wifi-iface
	option device   radio0
	option network  wwan
	option mode     sta
	option ssid     VongerWifi
	option encryption psk2
	option key      PasswordForWifi

If your house router has taken 192.168.1.1 as its IP address, you have to change the setting in /etc/config/network, set openwrt ip to other, so it will not conflict with your house router in STA mode. The ip in example is 192.168.61.1.

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.61.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

After that, looks everything works fine. My computer is able to connect to VoCore and VoCore is able to connect to internet through my wifi. But the only problem is my computer can not connect to internet through VoCore, maybe I have to setup a route on the board, will study on that later.

Antenna Test

About 10 meters from my home router(half is walled)
X-Y, Y-Z, X-Z direction for 10 times test, average value:

YAGEO:CAN4311153002451K(4dbi), 5.3 x 2.0 -> -70dBm
Supermax: IAN0201(2dbi), 5.2 x 2.0 -> -72dBm
Sunlord: SLDA72-2R470G-S1(2.5dbi) 5.0 x 2.0 -> -68dBm
Rainsun: AN3216-245 3.2×1.6(0.5dbi) -> -72dBm
????: PCB IPX antenna -> -80dBm

IMG_20140513_110050

 

So, after that test, remove the IPX for more clearance zone is a better choice.

Crying for soldering BGA RT5350

IT IS SO HARD!!!

I have made 8 VoCore v0.5 but only 2 works, Rest are all NG at BGA part…

The problem is my paste is Sn-Bi-Ag(176℃), but BGA balls are Sn-Ag-Cu(226℃),  I make the hot air to 320℃ the balls are melted down but can not touch and connect to PCB pads.

After serval test, I find a way. Paste under BGA is necessary, put paste on PCB BGA part first, then put RT5350 on that, MUST perfectly on its top. Then use hot air 220℃ until paste is melted about 30 seconds. Rise to 280℃ about 30 seconds, balls and paste will combine to one. After cool down, everything is just fine.

IMG_20140509_173642