VoCore2: Wifi driver(mt7628.ko) for LEDE 2

Last time I have success make the driver work, but it is not done.

Currently the log is like this, call “ifconfig ra0 up”

......
[  113.627999] mt7628_switch_channel(): Switch to Ch#9(1T1R), BBP_BW=0
[  113.634363] SYNC - BBP R4 to 20MHz.l
[  113.935695] [PMF]ap_pmf_init:: apidx=0, MFPC=0, MFPR=0, SHA256=0
[  113.941908] MtAsicSetRalinkBurstMode(2821): Not support for HIF_MT yet!
[  113.948644] MtAsicSetPiggyBack(746): Not support for HIF_MT yet!
[  113.982402] mt7628_switch_channel(): Switch to Ch#4(1T1R), BBP_BW=1
[  113.988785] MtAsicSetTxPreamble(2800): Not support for HIF_MT yet!
[  113.995163] MtAsicSetPreTbtt(): bss_idx=0, PreTBTT timeout = 0xf0
[  114.001379] Main bssid = b8:d8:12:67:5f:b5
[  114.005593] <==== rt28xx_init, Status=0

But I stopped here, I can find the SSID in my computer wifi list, but I can not connect to it, the icon on computer(macbook) is keeping in “connecting” status. I think I must miss some key steps, normal log should be like this.

[  449.410000] <==== rt28xx_init, Status=0
[  449.540000] device ra0 entered promiscuous mode
[  449.540000] br-lan: port 2(ra0) entered forwarding state
[  449.550000] br-lan: port 2(ra0) entered forwarding state
[  451.550000] br-lan: port 2(ra0) entered forwarding state

After ifconfig up, there is no log about ra0 entered forwarding state :p I am a noob again, haha. If you reader happen to know my mystery issue, please leave a message to this post 🙂

Here is my compiled mt7628.ko for lede, do not depends on other kernel module, my command: "insmod mt7628.ko" and "ifconfig ra0 up" should make it work.

Also mediatek driver do not support openwrt uci interface, Linkit driver is using iwpriv to setup everything, another way is to use a config file in /etc/wireless/mt7628/mt7628.dat.

You can download here and copy to your lede.mt7628.dat

PS: the developing version lede is broken for VoCore2, lol, I guess somebody modify uart2 interrupt, now uart2 can not input any command to console, only able to output log to console, sad 🙂

2 thoughts on “VoCore2: Wifi driver(mt7628.ko) for LEDE 2

  1. garam

    Problem… VoCore2 Ultimate.

    _________
    / /\ _ ___ ___ ___
    / LE / \ | | | __| \| __|
    / DE / \ | |__| _|| |) | _|
    /________/ LE \ |____|___|___/|___| lede-project.org
    \ \ DE /
    \ LE \ / ———————————————————–
    \ DE \ / Reboot (SNAPSHOT, r4631-77645ff)
    \________\/ ———————————————————–

    root@LEDE:/# insmod mt7628.ko
    [ 92.713570] mt7628: Unknown symbol mips_dma_alloc_coherent (err 0)
    [ 92.719957] mt7628: Unknown symbol mips_dma_free_coherent (err 0)
    [ 92.726404] mt7628: Unknown symbol __dma_sync (err 0)
    failed to insert /lib/modules/4.9.37/mt7628.ko
    root@LEDE:/#

    1. vongervonger Post author

      Oh, this kernel is 4.9.37, I compile it under LEDE(Linux 4.4), maybe that is the problem?

Comments are closed.